Trabajar con PHP y Flex en el mismo Framework

Usar PDT 2.0 y Flash Builder 4.1 en el mismo framework es algo muy simple de lograr ya que ambos son plugins de Eclipse.

Los pasos para instalar PDT como plugin en una instalación previa de Eclipse se pueden encontrar aquí.

Advertencia: Flash Builder esta basado sobre la versión 3.4 de Eclipse (alias Ganymede), por lo tanto, se debe usar la versión 2.0 de PDT preparada para esta versión.

Segun la wiki de eclipse, estos son los pasos a seguir:

  1. Ir al menu Help > Software Updates… > Available Software > Manage Sites…
  2. Usando el boton Add, agregar la direccion http://download.eclipse.org/technology/dltk/updates-dev/1.0M4-PDT-2.0/
  3. Nuevamente, agrega la direccion http://download.eclipse.org/tools/pdt/updates/2.0/
  4. Presiona el boton Manage Sites y habilita el sitio de actualización de Ganymede (http://download.eclipse.org/releases/ganymede/) si es que no se encuentra habilitado. Los sitios habilitados son los marcados con el check.

    Activando el sitio de actualización de Ganymede

    Activando el sitio de actualización de Ganymede

  5. Ahora debes seleccionar que paquetes vas a instalar. Selecciona los siguientes paquetes:
    En DLTK / Dynamic Languages Toolkit / Seleccionar Dynamic Languages Toolkit – Core Frameworks

    Seleccionando DLTK Core
    Seleccionando DLTK Core


  6. En PDT Update Site / PDT SDK 2.0.1 / Seleccionar PDT Runtine Feature
    Seleccionando PDT

    Seleccionando PDT

    Nota: En las imagenes no tengo seleccionado el paquete descrito porque yo ya lo tengo instalado.

  7. Hecho esto, dale un clic en el botón Install.
  8. Acepta la condiciones y espera a que termine la instalación. Cuando te pida reiniciar Eclipse lo haces.

Suerte en tu proyecto!

    Deja un comentario

    Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.